Atheros-Shit

in Drivers

Atheros

Estamos aqui para, novamente enfrentar mais um problema Classico e velho do Software LIvre, os malditos driver proprietários… Opa mas espera antes de vocês reclamarem, o problema NUNCA será o software livre, e sim a propriedade de sobre o software que impede que as coisas funcionem claramente no Linux, por muito tempo tivemos problemas com os Drivers da BROADCOM, (eu mesmo aprendi a compilar o driver e arrumar o fonte pra funcionar em kernels atuais), poré depois da Brodcom ter estabilizado, o que nossa fornecedora de noteboks DELL apronta?? Muda o driver pra porcaria da Artheros, que vai saber o porque, essa empresa MUI solicita, nem disponibiliza o fonte para compilar, e quando vamos no site , dessa empresa MUI amiga, claramente ela diz “Não distribuimos os drivers, ele vai junto com compra do equipamento e blablabl”… Que em bom português chulo de buteco é… “FODAM-SE VOCES que gostam de liberdade, tamo cagando proceis”. Mas como nem tudo esta perdido, exite um capeão, Fabian Olesen que vems pra nos salvar, e disponibiliza os binarios funcionais em seu site GIT. Então vamos pao procedimento KIBADO do fórum do ArchLinux que por sua vez foi Kibado de um fórum do Ubuntu.

Resumo do procedimento: Basta renomear e criar um diretorio, copiar os driver pra dentro , dar permissão de execução e ser feliz.

  1.  #cd /lib/firmware/ath10k/QCA6174/hw3.0/
  2.  #mv hw3.0/ hw3.0_old
  3.  #mkdir hw3.0
  4.  #wget https://github.com/FireWalkerX/ath10k-f … n?raw=true
  5.  #mv <Nome estranho que o arquivo pode vir > board-2.bin
  6.  #wget https://github.com/FireWalkerX/ath10k-f … n?raw=true
  7.  #mv <Nome estranho que o arquivo pode vir > firmware-4.bin

Hoje no dia Sex Jun 17 21:51:31 BRT 2016 tive que adicionar mais uma cosita , fiz uma copia do arquivos sem o -bin ficou assim:

board-2.bin  board.bin  firmware-4.bin  firmware.bin

  1. #chmod +x *
  2. #reboot
  3. #pacman -S be-happy (Isso é zueira)

Ps: m eu sistema Linux alice-work 4.6.2-1-ARCH #1 SMP PREEMPT Wed Jun 8 08:40:59 CEST 2016 x86_64 GNU/Linux

Kibado daqui: https://bbs.archlinux.org/viewtopic.php?id=208874

 

PS: apos atualização de kernel, o placa parou de funcionar, então segue os passos que fiz pra voltar a funfar.

————————- Atualização 16/08/2016——————————————————–

Clonei todo o o git do kvalo, baixei no modo noob via HTTP mesmo, descompactei em qualquer lugar do meu host, então, renomeei todo diretorio ath

#mv  /lib/firmware/ath10k/  /lib/firmware/ath10k_naoescaneia/

copiei todo diretorio do kavalo pra ath

#cp -rvf /home/ltardochi/Downloads/ATH/ath10k-firmware-master_kavalo/  /lib/firmware/ath10k

#chmod 775 -R /lib/firmware/ath10k

E ai minha wireless passou a funcionar, nota importante é que eu tambem instalei um pacote pacman -S crda

Bom fica a dica ae,  tentei sem instalar o pacote se não funcionar instale o pacote e descompente a opção do BR no arquivo de conf
#vim /etc/conf.d/wireless-regdom

Dae passou a funfar saporra!

 

ps; Kibado daqui: https://bbs.archlinux.org/viewtopic.php?id=204871

Write a Comment

Comment